Welcome to Linux Knowledge Base and Tutorial
"The place where you learn linux"
The ONE Campaign to make poverty history

 Create an AccountHome | Submit News | Your Account  

Tutorial Menu
Linux Tutorial Home
Table of Contents

· Introduction to Operating Systems
· Linux Basics
· Working with the System
· Shells and Utilities
· Editing Files
· Basic Administration
· The Operating System
· The X Windowing System
· The Computer Itself
· Networking
· System Monitoring
· Solving Problems
· Security
· Installing and Upgrading
· Linux and Windows

Glossary
MoreInfo
Man Pages
Linux Topics
Test Your Knowledge

Site Menu
Site Map
FAQ
Copyright Info
Terms of Use
Privacy Info
Disclaimer
WorkBoard
Thanks
Donations
Advertising
Masthead / Impressum
Your Account

Communication
Feedback
Forums
Private Messages
Surveys

Features
HOWTOs
News Archive
Submit News
Topics
User Articles
Web Links

Google
Google


The Web
linux-tutorial.info

Who's Online
There are currently, 63 guest(s) and 0 member(s) that are online.

You are an Anonymous user. You can register for free by clicking here

  
Linux Knowledge Base and Tutorial: Forums



Linux Tutorial :: View topic - Crash and Burn - Apache hitch...
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Crash and Burn - Apache hitch...
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Linux Tutorial Forum Index -> Networking
View previous topic :: View next topic  
Author Message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Thu Jun 29, 2006 11:21 am    Post subject: Crash and Burn - Apache hitch... Reply with quote

Hi, me again

What does the guy who has just rebuilt a dead linux system from scratch (learning how to do it along the way) - do next?

He crashes and burns the system and does it again! Twisted Evil

Yep, I thought I had it all running hunky dory, but there were things not quite right... I felt confident to take it all apart and re-build it and surprised myself by getting back to the stage where I was at the end of my last post - what took me a few weeks to do, I did in a day!

This time, I did a lot more things right - once the operating system was up and running, I went ahead and loaded the apps:

First came Samba without which I could not talk to the outside world. This was the cause of my initial cry for help - I installed locally as I did the first time round with no errors.

This done, I could now use apt-get to download and install the rest of the "LAMP" apps. Everything installed much cleaner than the first time around without all the strange errors and missing files. Apache2 and mysql-server started on re-boot and I can talk to mysql at command line level. So why this post? Well, I'm still green in experience terms and still have a long way to go - and I've hit another problem that is taxing the old brain cell!

I've got to the point where I can open apache from my Firefox browser and do the phpinfo bit - that's more than I could before. I can also display the initial apache index page telling you that if you can see this you've done something right...

What I can't do is open the phpmyadmin homepage. I get a pop-up telling me:

[quote]
"You have chosen to open

< this bit is blank >

which is a: application/x-httpd-php
from httpd//192.168.0.112

What should Firefox do with this file?
[/quote]

On our live server, Firefox simply opens the phpmyadmin index.php and I'm in to the mysql database. I've checked the setups of both systems and they seem to be the same (of course, this is where I've probably missed something). My development system is meant to mirror as closely as possible the live server, so its baffling that Firefox can open one index.php file but not another identical one on a different system.

I've checked out the htaccess file - as per manual it does contain the line:

AddType application/x-httpd-php .php

I added this line to httpd.conf for good measure (some manuals say to do this) and restarted apache. Still no good.

Anyone had a similar problem, or know how to get round it?
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Thu Jun 29, 2006 6:26 pm    Post subject: Reply with quote

I had a similar problem a while back, and ffreeloader's suggetion helped (http://www.linux-tutorial.info/ftopic-841-previous.html). Still, I think php scripts can be processed either by cgi, or by an apache php module.

I recently setup Debian testing with Apache2, php5 and mysql 5.0 and it did the php stuff without cgi module. I still don't see why that wouldn't work with php4.

I think you need to install at least libapache2-mod-php4 to make apache2 and php work together.

As you are trying to reproduce your production server, maybe you'll have to check what is installed on it. To do that you can use the command [code:1]dpkg -l[/code:1]
thats -l for list. Installed packes will have ii in front of them on the list.

To look for a package which names or descriptions have 'mod' in it, you can do something like [code:1]dpkg -l |grep mod[/code:1]
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Fri Jun 30, 2006 8:44 am    Post subject: Reply with quote

Thanks guys, I checked and while I have libapache-mod-php4 I don't have php4-cgi.

But before I did anything this morning, I was just curious to know what error MS Internet Explorer would throw at me if I tried to open phpmyadmin from there. So with a smirk at the ready I opened an IE window... and wouldn't you know it, damn thing worked!!! Confused

It looks exactly as it should and I can open the default mysql database - I can feel some seriously enjoyable sql playtime coming on today Smile

But the problem remains - somewhere in my configuration I'm telling it to work in IE and not Firefox. I just don't know where yet.

Right now, I'm installing php4-cgi and that long list of related packages Debian tells me I need too, (I think I already have some of them) then I'll restart apache and see what I can see. I have a feeling I need to go through some config files as well...
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Fri Jun 30, 2006 12:44 pm    Post subject: Reply with quote

weird.
When Firefox asks "what shloud ff do with this file?", could you save it, open it with a text editor (notepad or so), and see what's inside ? Could be either some php statements, or html.

Actually, you should do this without the cgi module installed, because theproblem is likely to disappear after you installe it.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Fri Jun 30, 2006 1:02 pm    Post subject: Reply with quote

Wierd indeed! I downloaded and opened the file in PSPad and its the index.php default for phpmyadmin (which I imagine it should be).

I also checked apache2.conf and there IS some code in there with:

[code:1]BrowserMatch "Mozilla/2" nokeepalive[/code:1]

and the same for MSIE. Same as my live system. I checked and it still opens ok in IE and the live index.php opens fine in both IE and Firefox - very strange...[/code]
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Fri Jun 30, 2006 2:01 pm    Post subject: Reply with quote

not sure if we understand each other.
If you read the file that firefox won't display, do you see html code , like
[code:1]
<?xml version="1.0" encoding="utf-8"?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en" dir="ltr">
<head>
<link rel="icon" href="./favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" href="./favicon.ico" type="image/x-icon" />
[/code:1]

or something that looks like the following ?
[code:1]
<?php
/* $Id: index.php,v 2.33 2006/01/17 17:02:28 cybot_tm Exp $ */
// vim: expandtab sw=4 ts=4 sts=4:
/**
* forms frameset
*
* @uses libraries/common.lib.php global fnctions
* @uses libraries/relation.lib.php table relations
[/code:1]

both are phpmyadmin/index.php, but the 2nd is the actual file as it exists on your server, the first is the html produced from it and sent to firefox by apache.

The process of rendering a php file in a browser is something like:
browser asks apache for index.php (http get index.php)
apache sends index.php to php interpreter
php interpreter processes php statements in index.php, which results in html code
php gives html back to apache
apache sends html to browser
browser reads and interpretes html and builds a page to show to user

I'm trying to figure out what does NOT happen in the faild firefox case that does happen in the succesfull cases. one possibility is that the processing of php to html does not happen. That, we can check by looking at the contents of the files that firefox receives.

An other possible reason is that the resulting html contains code that firefox does not know how to handle (but IE for some reason can, eg by ignoring the things it doesn't understand) -- and then your live system possibly pocesses php differently from your dev system (and we need to find out the difference).

So i think looking at the source of the pages as they are presented to firefox might give us a clue as to what to look for next.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Fri Jun 30, 2006 4:20 pm    Post subject: Reply with quote

Mmm, what firefox got me to download was the whole /phpmyadmin/index.php file, php and html. I think if firefox had tried to process the php it would have output something - even if it was just raw text. So I'm guessing it didn't know what to do with it so treated it as a file to be downloaded.

What's even stranger is I did what every good manual told me to do and made a small "test.php" file with "phpinfo()" inside - and firefox displays that just fine. Its sitting on the same directory as index.php.

I'm sure the answer is something annoyingly simple. But its Friday and its nearly time to go home and enjoy the weekend (computer-free). I'll be back on the case Monday...
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Sun Jul 02, 2006 8:28 pm    Post subject: Reply with quote

beats me.
[quote]So I'm guessing it didn't know what to do with it so treated it as a file to be downloaded. [/quote]
You're right, except for the fact that Firefox is not to do the processing, apache+php is (server-side scripts !).

If your test.php with phpinfo() works, obviously your apache&php can process php. So the only thing i can still think of is that there's something in the phpmyadmin source code that the php engine on your dev machine can't handle well.

I noticed that my phpmyadmin uses the new style long php tags, like[code:1]<?php ... ?>[/code:1].
Does yours too ?
Does your test.php use the short tags like these ?
[code:1]<? ... ?>[/code:1]

If so, does it still work when you replace the opening tag by the long one ?

Can't really imagine it would make a difference, but its easy to try and other than that, i'm clueless.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Mon Jul 03, 2006 4:26 pm    Post subject: Reply with quote

Just a quickie - I had other problems today so no time for testing. The php did use long tags:-
[code:1]<?php ?>[/code:1]
so that's not it either. I think I've now got my head round the idea that apache+php does the server-side scripts bit, not the browser - so there really shouldn't be any reason this is happening - the index.php firefox is trying to open is the default page that came with the apache download (exactly the same as on my live system) untouched by my clumsiness (!!) so its not that either.

Hopefully I will have more time to test tomorrow.
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Mon Jul 03, 2006 8:50 pm    Post subject: Reply with quote

still wondering what can be happening in phpmyadmin, php and/or apache with other php files that does not happen when you browse to phpmyadmin/index.php, and still thinking there's something in phpmyadmin that php4 can't handle.

the last straws:

- did you install php-mysql ? it's required for php to talk to mysql, so maybe phpmyadmin expects it, and behaves badly if it isn't there.

- in which order did you install the packages ? some install scripts check for the presence of other packages to adapt the configuration of ther package thats being installed. for a LAMP, a suitable order would be
- apache
- mysql
- php4 (or5) + libapache2-mod-php4 + php-mysql
- phpmyadmin (or any other php application)

And - as I was reading back the previous posts :
I noticed that sometimes you mention apache (as in libapache-mod-php4), sometimes apache2 (as in apache2.conf). could it be you're running both apache and apache2, and/or that you have some of the php stuff meant for apache (version1) while it should be for apache2 ? or vice versa ?
While bot apache and apache 2 are 'the apache web server', there are probably enough differences between the versions to make some stuff break if you don't have the modules match the version. Although that would be strange too - apt usually takes care of those dependencies very well.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Tue Jul 04, 2006 10:18 am    Post subject: Reply with quote

Still scratchin' my head too. When I re-installed everything, I followed the Ubuntu LAMP install manual instructions, which said to install in this order:

1. Apache2

2. php4 + libapache2-mod-php4

3. mysql-server + libapache2-mod-auth-mysql + php4-mysql

4. phpmyadmin
------------------------------------------
5. php4-cgi (added on ffree's advice)

I checked using "dpkg -l" and apache2 is not mixed with apache. Koen, I noticed your advice was to install mysql before php - might that make a difference? I read another manual that advocates installing mysql before php too. However, on my system apt-get downloads/installs from Ubuntu (which links to Debian packages) so I though it best to follow the Ubuntu instruction manual - if it was wrong there would be lots of posts from users pointing out the error. Maybe its one of those "chicken or egg" scenarios!

Interestingly, on re-reading those instructions, the manual does mention:

[quote]Troubleshooting

Does your browser ask if you want to [b]download the php[/b] file instead of displaying it? If Apache is not actually parsing the php after you restarted it, install libapache2-mod-php4. It should be installed when you install the php4 package, but some users have reported that it wasn't for them. You may also need to actually enable it, by doing sudo a2enmod php4 [/quote]

I followed that advice as part of the install instructions as a matter of course, along with enabling the module for good measure!

I know php4-cgi got added on the end, but I had the problem before I did that (installing php4-cgi was to try and fix the problem), so I don't think it makes a difference(??)

There is one other thing that I have just spotted - in the apache2.conf file the [b]User[/b] and [b]Group[/b] are both set to [b]www-data[/b] - a default that came with the package no doubt. This group/user is set in the /etc/group and /etc/passwd files.

The live system's httpd.conf file (there is no apache2.conf - its an older setup) has:
[b]User httpd
Group #-1[/b]

What's in a name? I've seen somewhere that user names have to be equivialenced to windows, ie root=administrator. Maybe there is no equivalence to www-data on windows. Or is this going off on the wrong tangent - a red herring, perhaps?
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Tue Jul 04, 2006 8:47 pm    Post subject: Reply with quote

[quote]Koen, I noticed your advice was to install mysql before php - might that make a difference? I read another manual that advocates installing mysql before php too. [/quote]
It could, as some pre- or post install scripts check for the presence of other packages config files and sometimes even modify them (so if that package is not there yet, the result will be different than when it is.
In this case I don't think it really matters - it was a hunch, and you're right that if in this case it did matter, users would have been posting comments in ubuntu's forums already.
I prefer the order i proposed because i saw it in howto's and manuals as wel, and it make sense to me : get apache and mysql working (and configured the way you want it), then add the glue : php + the modules that allow php to interact with both apache and mysql.

[quote]I've seen somewhere that user names have to be equivialenced to windows, ie root=administrator.[/quote]
I think that only makes sense if you want windows users to access samba shares - it simplifies user management and the windows user name will be sent to samba and allow access automatically if an user name / password exists on the linux/samba system

apache (with or without php and mysql) does not need to know, in fact it doesn't care whether it's serving webpages to a Linux or a Windows system. Something like that would only come into play when you want to use LDAP authentication e.g. to let apache authenticate the users
by querying Microsoft Active Directory. We're not quite there yet Smile

The www-data user looks ok to me. It's the account apache uses to access files etc. so as long that that account has sufficient access to the directories apache needs to read from, it's OK. If you compare with windows : windows usually uses the SYSTEM account for its services, but you could (some say : should) create any user account, grant it access to directories, and let the service run under whith that account's credentials.
But it never hurts to check (with the command ffreeloader posted).


I was wondering : if you want you could sent me the phpmyadmin index.php that firefox lets you download so I can have a closer look, see how it behaves on a computer here, or compare it to what i have here. I do mean the downloaded version, i.e. after it's (or should have) been processed by appache/php and sent to firefox.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Wed Jul 05, 2006 11:01 am    Post subject: Reply with quote

Koen, I think I might save you a bit of unnecessary headscratching... the file that was downloaded by firefox is exactly as it is on the linux - I compared them line for line.

Worse still - and its one of those simple things I overlooked (I had one of those "why-don't-I-try-it-this-way" moments) - when I told firefox to open the file using the fully qualified file name, ie

httpd://192.168.0.101/phpmyadmin/index.php

...it opened it! That made me sit bolt upright and swear... I should have done that before ploughing through that file!

Before this minor brainwave, in order to open index.php, I was just using the line

httpd://192.168.0.101/phpmyadmin/

and expecting firefox to open "index.php" as it should default to (and obviously Internet Explorer did) - and it didn't. It made me re-look at the error pop-up I got:
[quote]
"You have chosen to open



which is a: application/x-httpd-php
from httpd//192.168.0.112

What should Firefox do with this file? [/quote]

The blank space should have given me the clue. If firefox knew what it was opening (ie index.php) it would have opened it. If it was trying to open something else, the filename would have appeared in the blank space.

I remember seeing a config file somewhere with "index.html .htm .php" etc. Maybe its not set properly. I'll have a look around and find it...
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Wed Jul 05, 2006 5:22 pm    Post subject: Reply with quote

sh*t.
It's always easier in hindsight, but as you say, I noticed that peculiar 'blank' too, while you'd expect firefox to say "can't open index.php', what do you want me to do with it ?" -- and then didn't give it much thought as the error was soo much like one I had seen before.
Good lesson - isn't that what we always tell other people : read the messages !

Oh well; something annoyingly simple indeed. emphasis on annoying.

I think what you're looking for is in /etc/apache2/apache.conf :
[code:1]
DirectoryIndex index.html index.cgi index.pl index.php index.xhtml
[/code:1]
it tells apache to look for any of the given files (index.....) if it receives an URL like http://servername/foo/dirname where dirname is a directory

So, let's see if that fixes it.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Fri Jul 07, 2006 4:09 pm    Post subject: Reply with quote

Well...

I checked apache2.conf and index.php was there amongst the others (I knew I'd seen it somewhere!) So that wasn't it. My only other thought is that the "directory" I'm pointing to is a symlink. Surely not...
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Mon Jul 10, 2006 8:04 pm    Post subject: Reply with quote

[quote]My only other thought is that the "directory" I'm pointing to is a symlink. Surely not...[/quote]
Not quite clear what you mean by that.
Symlinks are rather transparant, i.e. if your browser sends a 'GET http://your_server/phpmyadmin/' to the server, it doesn't care whether that's a relal directory in your webserver's root, or a link to some other directory elsewere on your filesystem.

What happens if you replace phpmyadmin/index.php with a different index.php (eg rename your test.php and put it there) ? Does that work ?

The 'redirect to index file if directory name is given' thing only works if the apache module mod_dir is installed, but that should always be the case as it is compiled into apache2. you can check by executing apache2 -l (that's l for list, again).
And to explain why IE is not effected: I believe Internet Explorer handles this redirect client-side to better serve its users, where other browsers stick to the protocol and expect this to happen server-side, or not at all Smile

One more :
Is there a difference whether you do http://server/phpmyadmin or http://server/phpmyadmin[b]/[/b] (notice the trailing slash) ?
If one works and the other doesn't, we may be on to something.
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Tue Jul 11, 2006 9:26 am    Post subject: Reply with quote

Ok, I admit, the symlink comment was really clutching at straws... Crying or Very sad

Good idea to try the trailing slash - but no. I tried renaming my test.php to index.php, but still no. Mod_dir.c is in the list of installed modules. Mmm.

[quote]And to explain why IE is not effected: I believe Internet Explorer handles this redirect client-side to better serve its users, where other browsers stick to the protocol and expect this to happen server-side, or not at all [/quote]

I agree that has to be it. When I type http://server/phpmyadmin/index.php Firefox opens the page whether its the real index.php or the test.php. When I type http://server/phpmyadmin/ (or http://server/phpmyadmin ) Firefox asks if I want to save <blank> to disk. So something server-side in apache is not configured correctly - that something has to tell apache to recognise a file called index.php (or index.html ...etc) and it ain't doin' it!

This is the line of code copied from apache2.conf:

[code:1]
DirectoryIndex index.html index.cgi index.pl index.php index.xhtml
[/code:1]

It looks good to me - although maybe it should include index.xml (but that's for another day...)
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Tue Jul 11, 2006 10:18 am    Post subject: Reply with quote

[quote]So something server-side in apache is not configured correctly[/quote]
probably.
could you replace the phpadmin index.php by a regular html file (so .../pyhpmyadmin/index.html or .../pyhpmyadmin/index.htm) and see if that works when you http://server/phpmyadmin/

if it gives the same error as we can probably rule out any php-related error and focus on apache completely.

I'm also wondering whether there could be some influence from the filesystem eg the way directories are organized under apache server root, file ownership and/or permissions, or something to do with apache's web sites / virtual directories. But let's look into that after you've tried getting a plain index.html file from http://server/phpmyadmin/
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Tue Jul 11, 2006 10:48 am    Post subject: Reply with quote

Uh,oh I spoke too soon. Out of interest, I tried one more thing.

On the "apache-to-the-outside-world" directory ( /var/www ), where the symlink to phpmyadmin is sited, I made a new directory (called it "test" - such creativity...) and copied the famous test.php as index.php - then went to Firefox and... you know what's coming... http://server/test/ (and for good measure http://server/test ) and both displayed the phpinfo page. Rolling Eyes Mierde!

I can see two choices.

1. I reconfigure the whole thing so that apache2's "apache-to-the-outside-world" directory and /phpmyadmin are all together at /etc/apache2 (doing away with the need for a symlink to /usr/share/phpmyadmin) - lots of work and maybe for nothing!

2. I live with it as it is

3. I thought I said two choices... maybe there is another reason Firefox doesn't like this particular configuration. As you said, using a symlink should be transparent to the browser

I like a conundrum!
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Tue Jul 11, 2006 10:51 am    Post subject: Reply with quote

Oh, hi Koen, you must have posted that while I was typing the last one...
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Tue Jul 11, 2006 10:59 am    Post subject: Reply with quote

Yes, we can rule out php-related errors. I just tried the same thing with index.html on /phpmyadmin (http://server/phpmyadmin/) and firefox doesn't know what to do with it either. See my previous note... Crying or Very sad
Back to top
View user's profile Send private message
koen
Beginner


Joined: Sep 12, 2005
Posts: 224
Location: Belgium

PostPosted: Tue Jul 11, 2006 7:47 pm    Post subject: Reply with quote

[quote]2. I live with it as it is [/quote]
not really an option, is it ? Imagine the fear you'll experience everytime you so much as think about having to change some detail in apache configuration or need to use phpmyadmin for database maintenance ...
Wink

so, anything but phpmyadmin seems to work.
I'm thinking about a file ownership/permission issue again, but if apache was unable to read a file, it would return a 404 page not found, or a 500-something server internal error or access denied error, i suppose.

Anyway, could you check the owner and permissions on
/var/www
/var/www/phpmyadmin
/var/www/phpmyadmin/index.php
/usr/share/phpmyadmin

ls -al [i]path[/i] shows owners and permissions;
eg my /usr/share says

[code:1]
kdunix:/usr/share# ls -al | grep phpmyadmin
drwxr-xr-x 9 root root 4096 2006-07-01 23:03 phpmyadmin
[/code:1]
meaning that if phpmyadmin is owned by the user 'root' and the group 'root';
d: it's a directory
rwx : the user root can read, write and execute it
r-x : members of the group 'root' can read and execute
r-x : everyone else can read and execute

you never know ...
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Thu Jul 20, 2006 4:53 pm    Post subject: Reply with quote

Hi guys,

I haven't been on for a few days as I've had plenty of problems with the live server - so loads more experience has been gleaned in the face of adversity - but it has meant no time to work on my dev system.

I did check out the permissions and they all allow rwxr-xr-x (I even changed the phpmyadmin symlink to rwxrwxrwx!). That wasn't it. I added the alias to phpmyadmin in /etc/apache2/sites-enabled/000-default and checked out the config.inc.php file too. Still no.

I'll have to put it on the back burner for a while longer as there's lots of problems for me to sort out here. Watch this space...
Back to top
View user's profile Send private message
Tel
Beginner


Joined: Jun 09, 2006
Posts: 28
Location: Ex-London - Now Malaga, Spain

PostPosted: Thu Aug 03, 2006 1:27 pm    Post subject: Reply with quote

Hi guys,

I´m back, briefly... I ended up downloading a more recent version of phpmyadmin (2.8.2) after realising I was on an older version (2.6.1) just to see. Well of all things... problem solved!

An interesting trait of Ubuntu/Debian I discovered is that it won´t always get the most recent package with apt-get - I checked and found the later version of phpmyadmin on Debian´s site, but apt-get said there were no upgrades to install, so I had to download it manually. Maybe Debian is just making sure the release is absolutely safe before releasing it as stable.

More in the pipeline - I will be building another system soon to replicate a remote host for more authentic testing of our websites (they access mysql databases on two separate hosts). I´ll probably use a different flavour of Linux just to see what happens (isn´t it great to be able to do that Smile Maybe RedHat or similar, we´ll see - then I can post some more stuff as I hit the problems that I will invariably come across!

I´ll be back... Cool
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Linux Tutorial Forum Index -> Networking All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001-2007 phpBB Group
  

The Linux Tutorial is always looking for new contributors.


Login
Nickname

Password

Security Code
Security Code
Type Security Code


Don't have an account yet? You can create one. As a registered user you have some advantages like theme manager, comments configuration and post comments with your name.

Help if you can!


Amazon Wish List

Did You Know?
You can get all the latest Site and Linux news by checking out our news page.


Friends



Tell a Friend About Us

Bookmark and Share



Web site powered by PHP-Nuke

Is this information useful? At the very least you can help by spreading the word to your favorite newsgroups, mailing lists and forums.
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters. Articles are the property of their respective owners. Unless otherwise stated in the body of the article, article content (C) 1994-2013 by James Mohr. All rights reserved. The stylized page/paper, as well as the terms "The Linux Tutorial", "The Linux Server Tutorial", "The Linux Knowledge Base and Tutorial" and "The place where you learn Linux" are service marks of James Mohr. All rights reserved.
The Linux Knowledge Base and Tutorial may contain links to sites on the Internet, which are owned and operated by third parties. The Linux Tutorial is not responsible for the content of any such third-party site. By viewing/utilizing this web site, you have agreed to our disclaimer, terms of use and privacy policy. Use of automated download software ("harvesters") such as wget, httrack, etc. causes the site to quickly exceed its bandwidth limitation and are therefore expressly prohibited. For more details on this, take a look here

PHP-Nuke Copyright © 2004 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.23 Seconds